re = /([A-Z][a-z-]+)([A-Z][a-z-]+)/m
str = 'BorisovaSvetlana A.; KimHak Joong; PuXiaotao; LiuHung-wen*Liu-wenHung-wen*Liu-wen-benHung-wen-ben*PushpeshRajwanshi
'
subst = '\\1, \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result