import re
regex = re.compile(r"([A-Z][a-z-]+)([A-Z][a-z-]+)", flags=re.MULTILINE)
test_str = ("BorisovaSvetlana A.; KimHak Joong; PuXiaotao; LiuHung-wen*Liu-wenHung-wen*Liu-wen-benHung-wen-ben*PushpeshRajwanshi\n\n")
subst = "\\1, \\2"
result = regex.sub(subst, test_str)
if result:
print(result)