import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z][a-z-]+)([A-Z][a-z-]+)";
final String string = "BorisovaSvetlana A.; KimHak Joong; PuXiaotao; LiuHung-wen*Liu-wenHung-wen*Liu-wen-benHung-wen-ben*PushpeshRajwanshi\n\n";
final String subst = "\\1, \\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}