# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d)(?=[^\d\s])|(?<=[^\d\s])(?=\d)/ /gm;t' <<< "0ABCD TECHNOLOGIES SERVICES
ABCD0 TECHNOLOGIES SERVICES
ABCD 0TECHNOLOGIES SERVICES
ABCD TECHNOLOGIES0 SERVICES
ABCD TECHNOLOGIES 0SERVICES
ABCD TECHNOLOGIES SERVICES0
"