const regex = new RegExp('(?<=\\d)(?=[^\\d\\s])|(?<=[^\\d\\s])(?=\\d)', 'gm')
const str = `0ABCD TECHNOLOGIES SERVICES
ABCD0 TECHNOLOGIES SERVICES
ABCD 0TECHNOLOGIES SERVICES
ABCD TECHNOLOGIES0 SERVICES
ABCD TECHNOLOGIES 0SERVICES
ABCD TECHNOLOGIES SERVICES0
`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);