import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\d)(?=[^\\d\\s])|(?<=[^\\d\\s])(?=\\d)";
final String string = "0ABCD TECHNOLOGIES SERVICES\n"
+ "ABCD0 TECHNOLOGIES SERVICES\n"
+ "ABCD 0TECHNOLOGIES SERVICES\n"
+ "ABCD TECHNOLOGIES0 SERVICES\n"
+ "ABCD TECHNOLOGIES 0SERVICES\n"
+ "ABCD TECHNOLOGIES SERVICES0\n";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}