import re
regex = re.compile(r"(?<=\d)(?=[^\d\s])|(?<=[^\d\s])(?=\d)", flags=re.MULTILINE)
test_str = ("0ABCD TECHNOLOGIES SERVICES\n"
"ABCD0 TECHNOLOGIES SERVICES\n"
"ABCD 0TECHNOLOGIES SERVICES\n"
"ABCD TECHNOLOGIES0 SERVICES\n"
"ABCD TECHNOLOGIES 0SERVICES\n"
"ABCD TECHNOLOGIES SERVICES0\n")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)