#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\d)(?=[^\d\s])|(?<=[^\d\s])(?=\d)"
Local $sString = "0ABCD TECHNOLOGIES SERVICES" & @CRLF & _
"ABCD0 TECHNOLOGIES SERVICES" & @CRLF & _
"ABCD 0TECHNOLOGIES SERVICES" & @CRLF & _
"ABCD TECHNOLOGIES0 SERVICES" & @CRLF & _
"ABCD TECHNOLOGIES 0SERVICES" & @CRLF & _
"ABCD TECHNOLOGIES SERVICES0" & @CRLF & _
""
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)