#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(![!>#]?(?:(?=[^\s!>#$]|\s{2}|\s\$)|\$(?!\S)))\s*(.*)"
Local $sString = "Should not match:" & @CRLF & _
"! Hi" & @CRLF & _
"!! Hi" & @CRLF & _
"!> Hi" & @CRLF & _
"" & @CRLF & _
"Needs to match, with ! !! !> being in a group:" & @CRLF & _
"!Hi" & @CRLF & _
"!!Hi" & @CRLF & _
"!>Hi" & @CRLF & _
"! Hi" & @CRLF & _
"!! Hi" & @CRLF & _
"!> Hi" & @CRLF & _
"! Hi" & @CRLF & _
"!! Hi" & @CRLF & _
"!> Hi" & @CRLF & _
"" & @CRLF & _
"Ideally should not match:" & @CRLF & _
"!$OMP" & @CRLF & _
"" & @CRLF & _
"Ideally should Match:" & @CRLF & _
"! $" & @CRLF & _
"!$ OMP" & @CRLF & _
"!$ Hi"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")