using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(![!>#]?(?:(?=[^\s!>#$]|\s{2}|\s\$)|\$(?!\S)))\s*(.*)";
string input = @"Should not match:
! Hi
!! Hi
!> Hi
Needs to match, with ! !! !> being in a group:
!Hi
!!Hi
!>Hi
! Hi
!! Hi
!> Hi
! Hi
!! Hi
!> Hi
Ideally should not match:
!$OMP
Ideally should Match:
! $
!$ OMP
!$ Hi";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}