import Foundation
let pattern = ##"(![!>#]?(?:(?=[^\s!>#$]|\s{2}|\s\$)|\$(?!\S)))\s*(.*)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Should not match:
! Hi
!! Hi
!> Hi
Needs to match, with ! !! !> being in a group:
!Hi
!!Hi
!>Hi
! Hi
!! Hi
!> Hi
! Hi
!! Hi
!> Hi
Ideally should not match:
!$OMP
Ideally should Match:
! $
!$ OMP
!$ Hi
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)