import re
regex = re.compile(r"(![!>#]?(?:(?=[^\s!>#$]|\s{2}|\s\$)|\$(?!\S)))\s*(.*)", flags=re.MULTILINE)
test_str = ("Should not match:\n"
"! Hi\n"
"!! Hi\n"
"!> Hi\n\n"
"Needs to match, with ! !! !> being in a group:\n"
"!Hi\n"
"!!Hi\n"
"!>Hi\n"
"! Hi\n"
"!! Hi\n"
"!> Hi\n"
"! Hi\n"
"!! Hi\n"
"!> Hi\n\n"
"Ideally should not match:\n"
"!$OMP\n\n"
"Ideally should Match:\n"
"! $\n"
"!$ OMP\n"
"!$ Hi")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")