import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(![!>#]?(?:(?=[^\\s!>#$]|\\s{2}|\\s\\$)|\\$(?!\\S)))\\s*(.*)";
final String string = "Should not match:\n"
+ "! Hi\n"
+ "!! Hi\n"
+ "!> Hi\n\n"
+ "Needs to match, with ! !! !> being in a group:\n"
+ "!Hi\n"
+ "!!Hi\n"
+ "!>Hi\n"
+ "! Hi\n"
+ "!! Hi\n"
+ "!> Hi\n"
+ "! Hi\n"
+ "!! Hi\n"
+ "!> Hi\n\n"
+ "Ideally should not match:\n"
+ "!$OMP\n\n"
+ "Ideally should Match:\n"
+ "! $\n"
+ "!$ OMP\n"
+ "!$ Hi";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}