#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)#What_I_want_to_avoid: escaped elemets (odd no. of escape characters)" & @CRLF & _
"(?:[^\\]\\(?:\\\\)+|[^\\]\\)\${[^{}]*}" & @CRLF & _
"|" & @CRLF & _
"#What_I_want_to_match: unescaped element (or even no. of escape characters)" & @CRLF & _
"[^\\](?:\\\\)*(\${[^{}]*})"
Local $sString = "This${ is }a clear${ and simple} example ${string}, where {${only}} only the \${highlighted} parts should be selected allowing escaping and \\${unescaping} multiple times: \\\${not}, \\\\${in}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")