using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#What_I_want_to_avoid: escaped elemets (odd no. of escape characters)
(?:[^\\]\\(?:\\\\)+|[^\\]\\)\${[^{}]*}
|
#What_I_want_to_match: unescaped element (or even no. of escape characters)
[^\\](?:\\\\)*(\${[^{}]*})";
string input = @"This${ is }a clear${ and simple} example ${string}, where {${only}} only the \${highlighted} parts should be selected allowing escaping and \\${unescaping} multiple times: \\\${not}, \\\\${in}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}