const regex = /#What_I_want_to_avoid: escaped elemets (odd no. of escape characters)
(?:[^\\]\\(?:\\\\)+|[^\\]\\)\${[^{}]*}
|
#What_I_want_to_match: unescaped element (or even no. of escape characters)
[^\\](?:\\\\)*(\${[^{}]*})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#What_I_want_to_avoid: escaped elemets (odd no. of escape characters)
(?:[^\\\\]\\\\(?:\\\\\\\\)+|[^\\\\]\\\\)\\${[^{}]*}
|
#What_I_want_to_match: unescaped element (or even no. of escape characters)
[^\\\\](?:\\\\\\\\)*(\\${[^{}]*})', 'gm')
const str = `This\${ is }a clear\${ and simple} example \${string}, where {\${only}} only the \\\${highlighted} parts should be selected allowing escaping and \\\\\${unescaping} multiple times: \\\\\\\${not}, \\\\\\\\\${in}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}