$re = '/#What_I_want_to_avoid: escaped elemets (odd no. of escape characters)
(?:[^\\\\]\\\\(?:\\\\\\\\)+|[^\\\\]\\\\)\${[^{}]*}
|
#What_I_want_to_match: unescaped element (or even no. of escape characters)
[^\\\\](?:\\\\\\\\)*(\${[^{}]*})/mx';
$str = 'This${ is }a clear${ and simple} example ${string}, where {${only}} only the \\${highlighted} parts should be selected allowing escaping and \\\\${unescaping} multiple times: \\\\\\${not}, \\\\\\\\${in}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);