package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)#What_I_want_to_avoid: escaped elemets (odd no. of escape characters)
(?:[^\\]\\(?:\\\\)+|[^\\]\\)\${[^{}]*}
|
#What_I_want_to_match: unescaped element (or even no. of escape characters)
[^\\](?:\\\\)*(\${[^{}]*})`)
var str = `This${ is }a clear${ and simple} example ${string}, where {${only}} only the \${highlighted} parts should be selected allowing escaping and \\${unescaping} multiple times: \\\${not}, \\\\${in}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}