import re
regex = re.compile(r"""
#What_I_want_to_avoid: escaped elemets (odd no. of escape characters)
(?:[^\\]\\(?:\\\\)+|[^\\]\\)\${[^{}]*}
|
#What_I_want_to_match: unescaped element (or even no. of escape characters)
[^\\](?:\\\\)*(\${[^{}]*})
""", flags=re.MULTILINE | re.VERBOSE)
test_str = "This${ is }a clear${ and simple} example ${string}, where {${only}} only the \\${highlighted} parts should be selected allowing escaping and \\\\${unescaping} multiple times: \\\\\\${not}, \\\\\\\\${in}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")