re = /#What_I_want_to_avoid: escaped elemets (odd no. of escape characters)
(?:[^\\]\\(?:\\\\)+|[^\\]\\)\${[^{}]*}
|
#What_I_want_to_match: unescaped element (or even no. of escape characters)
[^\\](?:\\\\)*(\${[^{}]*})/mx
str = 'This${ is }a clear${ and simple} example ${string}, where {${only}} only the \\${highlighted} parts should be selected allowing escaping and \\\\${unescaping} multiple times: \\\\\\${not}, \\\\\\\\${in}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end