use strict;
my $str = 'This${ is }a clear${ and simple} example ${string}, where {${only}} only the \\${highlighted} parts should be selected allowing escaping and \\\\${unescaping} multiple times: \\\\\\${not}, \\\\\\\\${in}';
my $regex = qr/#What_I_want_to_avoid: escaped elemets (odd no. of escape characters)
(?:[^\\]\\(?:\\\\)+|[^\\]\\)\${[^{}]*}
|
#What_I_want_to_match: unescaped element (or even no. of escape characters)
[^\\](?:\\\\)*(\${[^{}]*})/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}