# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\/\*\s*ABCD[^*\/]*)\*\/\s*\/\*\s*Comment[^*:]+:(\s*\[\[[^][]*]]\s*\*\/)/\1#\2/gm;t' <<< "/* ABCD X 1111 */ /* Comment 1111: [[reason for comment]] */"