use strict;
my $str = '/* ABCD X 1111 */ /* Comment 1111: [[reason for comment]] */';
my $regex = qr/(/\*\s*ABCD[^*/]*)\*/\s*/\*\s*Comment[^*:]+:(\s*\[\[[^][]*]]\s*\*/)/mp;
my $subst = '\\1#\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";