const regex = new RegExp('(/\\*\\s*ABCD[^*/]*)\\*/\\s*/\\*\\s*Comment[^*:]+:(\\s*\\[\\[[^][]*]]\\s*\\*/)', 'gm')
const str = `/* ABCD X 1111 */ /* Comment 1111: [[reason for comment]] */`;
const subst = `\1#\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);