import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(/\\*\\s*ABCD[^*/]*)\\*/\\s*/\\*\\s*Comment[^*:]+:(\\s*\\[\\[[^][]*]]\\s*\\*/)";
final String string = "/* ABCD X 1111 */ /* Comment 1111: [[reason for comment]] */";
final String subst = "\\1#\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}