package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(/\*\s*ABCD[^*/]*)\*/\s*/\*\s*Comment[^*:]+:(\s*\[\[[^][]*]]\s*\*/)`)
var str = `/* ABCD X 1111 */ /* Comment 1111: [[reason for comment]] */`
var substitution = "\1#\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}