$re = '/(/\*\s*ABCD[^*/]*)\*/\s*/\*\s*Comment[^*:]+:(\s*\[\[[^][]*]]\s*\*/)/m';
$str = '/* ABCD X 1111 */ /* Comment 1111: [[reason for comment]] */';
$subst = "\1#\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;