re = /(\/\*\s*ABCD[^*\/]*)\*\/\s*\/\*\s*Comment[^*:]+:(\s*\[\[[^][]*]]\s*\*\/)/m
str = '/* ABCD X 1111 */ /* Comment 1111: [[reason for comment]] */'
subst = '\\1#\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result