# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^a-zA-Z0-9_-]+(?=.*\.\w+$)/-/gm;t' <<< "(800x800-png)MGC1000-03EPTD-021_RAL7035-5010.tif.png"