use strict;
my $str = '(800x800-png)MGC1000-03EPTD-021_RAL7035-5010.tif.png';
my $regex = qr/[^a-zA-Z0-9_-]+(?=.*\.\w+$)/mp;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";