const regex = /[^a-zA-Z0-9_-]+(?=.*\.\w+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Z0-9_-]+(?=.*\\.\\w+$)', 'gm')
const str = `(800x800-png)MGC1000-03EPTD-021_RAL7035-5010.tif.png`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);