re = /[^a-zA-Z0-9_-]+(?=.*\.\w+$)/m
str = '(800x800-png)MGC1000-03EPTD-021_RAL7035-5010.tif.png'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result