using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^a-zA-Z0-9_-]+(?=.*\.\w+$)";
string substitution = @"-";
string input = @"(800x800-png)MGC1000-03EPTD-021_RAL7035-5010.tif.png";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}