$re = '/[^a-zA-Z0-9_-]+(?=.*\.\w+$)/m';
$str = '(800x800-png)MGC1000-03EPTD-021_RAL7035-5010.tif.png';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;