#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[^a-zA-Z0-9_-]+(?=.*\.\w+$)"
Local $sString = "(800x800-png)MGC1000-03EPTD-021_RAL7035-5010.tif.png"
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)