import Foundation
let pattern = #"[^a-zA-Z0-9_-]+(?=.*\.\w+$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"(800x800-png)MGC1000-03EPTD-021_RAL7035-5010.tif.png"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)