using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\{([^}]+)\}";
string substitution = @"test";
string input = @"Hello ${world}. {This is} the ${apple}. You ${may} find the gravity";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}