import re
regex = re.compile(r"\$\{([^}]+)\}")
test_str = "Hello ${world}. {This is} the ${apple}. You ${may} find the gravity"
subst = "test"
result = regex.sub(subst, test_str)
if result:
print(result)