$re = '`\$\{([^}]+)\}`';
$str = 'Hello ${world}. {This is} the ${apple}. You ${may} find the gravity';
$subst = "test";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;