// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\$\{([^}]+)\}").unwrap();
let string = "Hello ${world}. {This is} the ${apple}. You ${may} find the gravity";
let substitution = "test";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}