re = /\$\{([^}]+)\}/
str = 'Hello ${world}. {This is} the ${apple}. You ${may} find the gravity'
subst = 'test'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result