const regex = new RegExp('\\$\\{([^}]+)\\}', 'g')
const str = `Hello \${world}. {This is} the \${apple}. You \${may} find the gravity`;
const subst = `test`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);