use strict;
my $str = 'Hello ${world}. {This is} the ${apple}. You ${may} find the gravity';
my $regex = qr`\$\{([^}]+)\}`p;
my $subst = 'test';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";