import Foundation
let pattern = #"\$\{([^}]+)\}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Hello ${world}. {This is} the ${apple}. You ${may} find the gravity"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"test"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)