import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\D+";
final String string = "\\n\n"
+ " \\t\\n\n"
+ " \\n\n"
+ " 4 290 €\\n\n"
+ " \\n\n"
+ " \\n\n"
+ " \\n\n"
+ " \\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}