const regex = /\D+/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\D+', 'gi')
const str = `\\n
\\t\\n
\\n
4 290 €\\n
\\n
\\n
\\n
\\n`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);