// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\D+").unwrap();
let string = "\\n
\\t\\n
\\n
4 290 €\\n
\\n
\\n
\\n
\\n";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}