use strict;
my $str = '\\n
\\t\\n
\\n
4 290 €\\n
\\n
\\n
\\n
\\n';
my $regex = qr/\D+/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";