$re = '/\D+/i';
$str = '\\n
\\t\\n
\\n
4 290 €\\n
\\n
\\n
\\n
\\n';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;