import re
regex = re.compile(r"\D+", flags=re.IGNORECASE)
test_str = ("\\n\n"
" \\t\\n\n"
" \\n\n"
" 4 290 €\\n\n"
" \\n\n"
" \\n\n"
" \\n\n"
" \\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)